Question
Your basket output reads "series does not exist" but you're sure it does.
Answer
Circumstances:
- In your basket output, a series is marked "Series does not exist."
- However, you have verified its existence using "View" mode.
Likely cause:
Extraneous TAB characters are appended to the mnemonics in the basket power editor. You probably compiled the list in a spreadsheet or word processor, and then pasted it into the Basket Power Editor. In doing so, you carried invisible hitchhikers.
Diagnostics:
- Open the basket. If necessary, switch mode to Power Editor. Place your insertion point (cursor) on the offending mnemonic, then hit END. Where did the point go? Is it floating to the right of the mnemonic, separated by a gap? Then you have excess whitespace.
- Examine the basket output in Microsoft Excel. Find the field with the mnemonic. Depending on the cell formatting, nonprinting characters may be displayed as small rectangles.
Fix:
In the Basket Power Editor or Basket Grid Editor, for each mnemonic, at both ends, carefully delete any whitespace characters.
Related problems:
Basket output message "Access denied." This means the series do exist but are not included among your subscriptions.
Commentary:
The class of "whitespace" characters includes the familiar SPACE, plus TAB, line feed (LF), carriage return (CR) and newline (NL). (The latter three act in concert, in a way that varies between Windows, Macintosh, and Unix operating systems.) "Nonprinting characters" include these and others.
The Excel workbook functions TRIM, CLEAN and SUBSTITUTE can remove whitespace and nonprinting characters. Please read their manual pages for specific usage.
The Data Buffet engine will detect and remove extraneous SPACE characters from mnemonics, but not other whitespace characters. The circumstance is too rare to warrant the additional processing load.